БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Программирование - Практика программирования

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

Если у Вас возник вопрос, как можно вообще напортачить с регламентными заданиями? Почитайте живые примеры из статьи -> Велостыли: Регламентные задания

Для экспериментов я использовал Платформы 8.3.10.2650 и 8.3.12.1412, конфигурации БСП 2.4.6.56 и 3.0.1.127.

Устанавливаем демо конфигурацию БСП и поехали! Работать будем со Справочником «Заметки». У него есть реквизит Содержание с типом ХранилищеЗначения, а это значит, туда много, что записать можно, ну и присутствуют другие реквизиты, с которыми тоже поработаем.

Содержание:

1 Один регламент

2 Регламент и форма с ручным запуском.

3 Два регламента, форма с ручным запуском и сохранение параметров для регламентов.

Рекомендации по отладке.

Задачи и решения.

Задача 1. Создать с помощью регламента новый элемент справочника Заметки и записать в реквизит содержание «Заметка создана регламентом в Время создания»

Создаем внешнюю обработку, назовем ее, например, «БСП_ДО_Регламенты»

Добавляем код в модуль:

// Возвращает сведения о внешней обработке.
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.4.5.71");
	
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
	ПараметрыРегистрации.Версия = "1.0.01";
	
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 1 регламент'");
	НоваяКоманда.Идентификатор = "Задача1Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	Возврат ПараметрыРегистрации;
	
КонецФункции

// Интерфейс для запуска логики обработки.
Процедура ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения) Экспорт
	
	// Диспетчеризация обработчиков команд.
	Если ИмяКоманды = "Задача1Регламент" Тогда
		Команда_ЗаДача1(ПараметрыВыполнения);
	КонецЕсли;
	
КонецПроцедуры

Процедура Команда_ЗаДача1(ПараметрыВыполнения)
	
	СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения);
		
КонецПроцедуры	

Процедура СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения)
	//Создаем новый элемент справочника
	ТекущийОбъект = Справочники.Заметки.СоздатьЭлемент();
	
	ДатаТекСеанса = ТекущаяДатаСеанса();
	
	//Формируем текст для Содержания
	ФорматированныйТекст = Новый ФорматированныйДокумент;
	ФорматированныйТекст.Добавить("Заметка создана регламентом в " + Строка(ДатаТекСеанса),Тип("ТекстФорматированногоДокумента"));
	
	ТекущийОбъект.Содержание = Новый ХранилищеЗначения(ФорматированныйТекст, Новый СжатиеДанных(9));
	
	ТекстHTML = "";
	Вложения = Новый Структура;
	ФорматированныйТекст.ПолучитьHTML(ТекстHTML, Вложения);
	
	ТекущийОбъект.ТекстСодержания	= СтроковыеФункцииКлиентСервер.ИзвлечьТекстИзHTML(ТекстHTML);
	
	ТекущийОбъект.ДатаИзменения 	= ДатаТекСеанса;
	ТекущийОбъект.Автор 			= ПараметрыСеанса.ТекущийПользователь;
	ТекущийОбъект.Пометка 			= Перечисления.ЦветаЗаметок.Красный;
	ТекущийОбъект.ДляРабочегоСтола	= Истина;
	
	ТекущийОбъект.Записать();
КонецПроцедуры

Сохраняем обработку и добавляем ее в нашу конфигурацию для тестов БСП демо.

Моя настройка: C 6 мая 2018 г. каждый день; по 23:59:59 каждые 60 секунд.

Записываем и проверяем.

Вот так просто можно добавить регламент, не изменяя типовой конфигурации. Когда-нибудь РЗ возможно можно будет добавлять через расширение, а пока можно использовать БСП.

Задача 2. В созданную нами дополнительную обработку необходимо добавить форму с возможностью ручного запуска регламентного задания. При этом в содержание надо писать создана заметка вручную или по регламенту.

Меняем код в модуле обработки:

// Возвращает сведения о внешней обработке.
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.4.5.71");
	//ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
	
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
	ПараметрыРегистрации.Версия = "1.0.02";
	
	//Открываем форму
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Форма задач по регламентам'");
	НоваяКоманда.Идентификатор = "НастроитьИВыполнитьЗадачиВручную";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
	НоваяКоманда.ПоказыватьОповещение = Ложь;
	
	//Регламент1
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 1 регламент'");
	НоваяКоманда.Идентификатор = "Задача1Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	Возврат ПараметрыРегистрации;
	
КонецФункции

// Интерфейс для запуска логики обработки.
Процедура ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения) Экспорт
	//Если в структуре параметров не передан вид запуска считаем что это запуск регламентом
	Если не ПараметрыВыполнения.свойство("ВидЗапускаРегламент") Тогда 
		ПараметрыВыполнения.Вставить("ВидЗапускаРегламент",Истина);	
	КонецЕсли;	
	
	// Диспетчеризация обработчиков команд.
	Если ИмяКоманды = "Задача1Регламент" Тогда
		Команда_ЗаДача1(ПараметрыВыполнения);
	КонецЕсли;
	
КонецПроцедуры

Процедура Команда_ЗаДача1(ПараметрыВыполнения)

	СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения);
		
КонецПроцедуры	

Процедура СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения)
	//Создаем новый элемент справочника
	ТекущийОбъект = Справочники.Заметки.СоздатьЭлемент();
	
	ДатаТекСеанса = ТекущаяДатаСеанса();
	
	//Формируем текст для Содержания
	ФорматированныйТекст = Новый ФорматированныйДокумент;
	
	//Добавили проверку регламент\форма
	ФорматированныйТекст.Добавить("Заметка создана " + ?(ПараметрыВыполнения.ВидЗапускаРегламент,"регламентом","вручную") + " в "+Строка(ДатаТекСеанса), Тип("ТекстФорматированногоДокумента"));
	
	ТекущийОбъект.Содержание = Новый ХранилищеЗначения(ФорматированныйТекст, Новый СжатиеДанных(9));
	
	ТекстHTML = "";
	Вложения = Новый Структура;
	ФорматированныйТекст.ПолучитьHTML(ТекстHTML, Вложения);
	
	ТекущийОбъект.ТекстСодержания	= СтроковыеФункцииКлиентСервер.ИзвлечьТекстИзHTML(ТекстHTML);
	
	ТекущийОбъект.ДатаИзменения 	= ДатаТекСеанса;
	ТекущийОбъект.Автор 			= ПараметрыСеанса.ТекущийПользователь;
	ТекущийОбъект.Пометка 			= Перечисления.ЦветаЗаметок.Красный;
	ТекущийОбъект.ДляРабочегоСтола	= Истина;
	
	ТекущийОбъект.Записать();
КонецПроцедуры	

Добавляем форму и создаем команду «Задание2»

&НаКлиенте
Процедура Задание2(Команда)
	Задание2НаСервере();
КонецПроцедуры

&НаСервере
Процедура Задание2НаСервере()
	ПараметрыВыполнения = новый Структура("ВидЗапускаРегламент",Ложь);
	ИмяКоманды = "Задача1Регламент";
	
	ОбрОбъект = РеквизитФормыВЗначение("Объект");
	ОбрОбъект.ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения);
КонецПроцедуры

Записываем и заменяем предыдущую дополнительную обработку на эту.

Проверяем результат:

Задача 3. Создать второе регламентное задание и сделать  так, чтобы можно было сохранять параметры настроек, текст содержания и цвет (Пометка). При выполнении заданий параметры заполняют элемент справочника «Заметки». Ранее созданная кнопка должна запускать выбранное задание.

Редактируем функцию СведенияОВнешнейОбработке в модуле обработки. Добавляем второе регламентное задание.

// Возвращает сведения о внешней обработке.
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.4.5.71");
	
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
	ПараметрыРегистрации.Версия = "1.0.06";
	
	//Открываем форму
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Форма задач по регламентам'");
	НоваяКоманда.Идентификатор = "НастроитьИВыполнитьЗадачиВручную";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
	НоваяКоманда.ПоказыватьОповещение = Ложь;
	
	//Регламент1
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 1 регламент'");
	НоваяКоманда.Идентификатор = "Задача1Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	//Регламент2
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 2 регламент'");
	НоваяКоманда.Идентификатор = "Задача2Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;

	Возврат ПараметрыРегистрации;
	
КонецФункции

К модулю вернемся позже. Переходим к редактированию формы.

Создаем параметр формы "ДополнительнаяОбработкаСсылка" с типом "СправочникСсылка.ДополнительныеОтчетыИОбработки"

Создаем реквизиты формы.

"РегламентноеЗаданиеСписок" с типом "Строка"

"СписокРЗ" с типом "ТаблицаЗначений"

                -"КлючРЗ" с типом "Строка"

                -"ТекстСодержания" с типом "Строка"

                -"Пометка" с типом "ПеречислениеСсылка.ЦветаЗаметок"

Переименовываем команду «Задание2» в команду «ВыполнитьРЗ», соответственно процедуру тоже приводим к такому имени.

Создаем команду «ЗаписатьИзменения»

Форму делаем вот такого вида

Подготовительные работы выполнены, переходим к программированию.

Список для списка РЗ и ключи РЗ будем брать из модуля обработки, из функции СведенияОВнешнейОбработке она Экспортная. Нас интересуют все команды где Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();

Дальше мы будем считывать параметры, сохраненные в обработке Хранить их будем в ХранилищеНастроек

Для того чтобы делать меньше телодвижений в модуле обработки пропишем структуру для чистых настроек, для этого создадим экспортную функцию ПолучитьЧистуюСтруктуруНастроек

//Чистые настройки
Функция ПолучитьЧистуюСтруктуруНастроек() Экспорт
	СтруктураДанных = Новый Структура;
	СписокРЗ = Новый ТаблицаЗначений;
	СписокРЗ.Колонки.Добавить("КлючРЗ");
	СписокРЗ.Колонки.Добавить("ТекстСодержания");
	СписокРЗ.Колонки.Добавить("Пометка");
	
	СтруктураДанных.Вставить("СписокРЗ",СписокРЗ);
	Возврат СтруктураДанных;
КонецФункции

Создаем процедуру ПриСозданииНаСервере

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ЗаполнитьЗаписаннымиДанными();
КонецПроцедуры
Процедура ЗаполнитьЗаписаннымиДанными()
	ОбрОбъект = РеквизитФормыВЗначение("Объект");
	
	//Читаем информацию по доп обработке
	ПолучитьСведеньяОбработки = ОбрОбъект.СведенияОВнешнейОбработке();
	
	//В ТЗ Команды будем забирать только регламенты
	ПараметрыОтбора = Новый Структура;
	ПараметрыОтбора.Вставить("Использование", ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода());
	СтрокиРЗ = ПолучитьСведеньяОбработки.Команды.НайтиСтроки(ПараметрыОтбора);
	
	ОбъектСсылка = Параметры.ДополнительнаяОбработкаСсылка;
	
	перСтруктураНормальная = Ложь;
	Если ЗначениеЗаполнено(ОбъектСсылка) Тогда	
		//Читаем ХранилищеНастроек
		перОбщиеПараметры = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ОбъектСсылка, "ХранилищеНастроек");
		СтруктураОбщиеПараметры = перОбщиеПараметры.Получить();
		
		Если Не ЗначениеЗаполнено(СтруктураОбщиеПараметры) Тогда 
			//записываем чистую структуру
			СтруктураОбщиеПараметры = ОбрОбъект.ПолучитьЧистуюСтруктуруНастроек(); 
		
		КонецЕсли;
		
		Если СтруктураОбщиеПараметры.Свойство("СписокРЗ") Тогда
			Если ТипЗнч(СтруктураОбщиеПараметры.СписокРЗ) = Тип("ТаблицаЗначений") Тогда 
				перСтруктураНормальная = Истина;	
	        КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
	МассивРЗ = Новый Массив;
	Если перСтруктураНормальная Тогда
		//Собираем данные для вывода на форму
		Для Каждого СтрокаРЗ Из СтрокиРЗ Цикл
			//Собираем Элементы.РегламентноеЗаданиеСписок.СписокВыбора
	        МассивРЗ.Добавить(СтрокаРЗ.Идентификатор);
			
			ПараметрыОтбора		= Новый Структура;
			ПараметрыОтбора.Вставить("КлючРЗ", СтрокаРЗ.Идентификатор);
			НайденныеСтрокиРЗ	= СтруктураОбщиеПараметры.СписокРЗ.НайтиСтроки(ПараметрыОтбора);	
			
			Если НайденныеСтрокиРЗ.Количество() = 0 Тогда 
				НовСтрока 			= СписокРЗ.Добавить();
	        	НовСтрока.КлючРЗ	= СтрокаРЗ.Идентификатор;	
			Иначе	
				Для Каждого нСтрокаРЗ из НайденныеСтрокиРЗ Цикл 
					НовСтрока = СписокРЗ.Добавить();
					ЗаполнитьЗначенияСвойств(НовСтрока,нСтрокаРЗ);
				КонецЦикла;	
			КонецЕсли;	
		КонецЦикла;	
	Иначе
		//Если настройки отсутствуют в сохраненных настройках, добавляем их в таблицу со значениями по умолчанию
		Для Каждого СтрокаРЗ Из СтрокиРЗ Цикл	
			//Собираем Элементы.РегламентноеЗаданиеСписок.СписокВыбора
			МассивРЗ.Добавить(СтрокаРЗ.Идентификатор);
			
			НовСтрока 					= СписокРЗ.Добавить();
	        НовСтрока.КлючРЗ			= СтрокаРЗ.Идентификатор;
	    КонецЦикла;	
	КонецЕсли;
	//Заполняем список заданий
	Элементы.РегламентноеЗаданиеСписок.СписокВыбора.ЗагрузитьЗначения(МассивРЗ);	
КонецПроцедуры

Создаем процедуру для команды «ЗаписатьИзменения»

&НаКлиенте
Процедура ЗаписатьИзменения(Команда)
	ЗаписатьИзмененияНаСервере();
КонецПроцедуры
&НаСервере
Процедура ЗаписатьИзмененияНаСервере()
	Если не ЗначениеЗаполнено(Параметры.ДополнительнаяОбработкаСсылка) Тогда 
		Сообщить("Запись работает только в режиме встроенной доп обработки!",СтатусСообщения.Важное);
		Возврат;	
	КонецЕсли;	
	
	СтруктураДанных = Новый Структура("СписокРЗ",СписокРЗ.Выгрузить());
	
	ДополнительнаяОбработкаОбъект = Параметры.ДополнительнаяОбработкаСсылка.ПолучитьОбъект();
	ДополнительнаяОбработкаОбъект.ХранилищеНастроек = Новый ХранилищеЗначения(СтруктураДанных);
	ДополнительнаяОбработкаОбъект.Записать();
КонецПроцедуры

Изменяем процедуру для команды «ВыполнитьРЗ»

&НаКлиенте
Процедура ВыполнитьРЗ(Команда)
	ВыполнитьРЗНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВыполнитьРЗНаСервере()
	Если не ЗначениеЗаполнено(РегламентноеЗаданиеСписок) Тогда 
		Сообщить("Выберите РЗ!!!",СтатусСообщения.Важное);
		Возврат;
	КонецЕсли;	
	
	ПараметрыОтбора		= Новый Структура;
	ПараметрыОтбора.Вставить("КлючРЗ", РегламентноеЗаданиеСписок);
	НайденныеСтрокиРЗ	= СписокРЗ.НайтиСтроки(ПараметрыОтбора);	
			
	Если НайденныеСтрокиРЗ.Количество() = 0 Тогда
		Сообщить("Не найдено параметров РЗ!!! "+РегламентноеЗаданиеСписок,СтатусСообщения.Важное);
		Возврат;
	КонецЕсли;	
	
	//ПараметрыРЗ формируем на клиенте, вдруг не записали в ТЗ изменения
	ПараметрыВыполнения = новый Структура("ПараметрыРЗ");
	ПараметрыВыполнения.Вставить("ВидЗапускаРегламент",Ложь);
	ИмяКоманды = РегламентноеЗаданиеСписок;
	
	ОбрОбъект = РеквизитФормыВЗначение("Объект");
	//Если вдруг умудрились задублировать в ТЗ регламенты
	Для Каждого СтрокаРЗ из НайденныеСтрокиРЗ Цикл 
	    ПараметрыВыполнения.ПараметрыРЗ = Новый Структура("ТекстСодержания,Пометка",
										СтрокаРЗ.ТекстСодержания,
										СтрокаРЗ.Пометка);
		ОбрОбъект.ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения);	
	КонецЦикла;	
КонецПроцедуры

Изменяем в модуле обработки процедуру «ВыполнитьКоманду»

// Интерфейс для запуска логики обработки.
Процедура ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения) Экспорт
	//Если в структуре параметров не передан вид запуска считаем что это запуск регламентом
	Если не ПараметрыВыполнения.свойство("ВидЗапускаРегламент") Тогда 
		ПараметрыВыполнения.Вставить("ВидЗапускаРегламент",Истина);	
	КонецЕсли;	
	
	// Диспетчеризация обработчиков команд.
	Если ИмяКоманды = "Задача1Регламент" 
		или ИмяКоманды = "Задача2Регламент" Тогда
		
		Если ПараметрыВыполнения.ВидЗапускаРегламент Тогда 
			ОбъектСсылка = ПараметрыВыполнения.ДополнительнаяОбработкаСсылка;	
			Если ЗначениеЗаполнено(ОбъектСсылка) Тогда	
				//Читаем ХранилищеНастроек
				перОбщиеПараметры = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ОбъектСсылка, "ХранилищеНастроек");
				СтруктураОбщиеПараметры = перОбщиеПараметры.Получить();
				
				Если Не ЗначениеЗаполнено(СтруктураОбщиеПараметры) Тогда 
					//записываем чистую структуру
					СтруктураОбщиеПараметры = ПолучитьЧистуюСтруктуруНастроек(); 
				
				КонецЕсли;
				
				Если СтруктураОбщиеПараметры.Свойство("СписокРЗ") Тогда
					Если ТипЗнч(СтруктураОбщиеПараметры.СписокРЗ) = Тип("ТаблицаЗначений") Тогда 
						
						//Все проверки прошли
						ПараметрыОтбора		= Новый Структура;
						ПараметрыОтбора.Вставить("КлючРЗ", ИмяКоманды);
						НайденныеСтрокиРЗ	= СтруктураОбщиеПараметры.СписокРЗ.НайтиСтроки(ПараметрыОтбора);
						
						Если НайденныеСтрокиРЗ.Количество() > 0 Тогда

							//Если вдруг умудрились задублировать в ТЗ регламенты
							Для Каждого СтрокаРЗ из НайденныеСтрокиРЗ Цикл 
								
								Если ПараметрыВыполнения.Свойство("ПараметрыРЗ") Тогда 
								
							    	ПараметрыВыполнения.ПараметрыРЗ = Новый Структура("ТекстСодержания,Пометка",
																СтрокаРЗ.ТекстСодержания,
																СтрокаРЗ.Пометка);
								Иначе
									ПараметрыВыполнения.Вставить("ПараметрыРЗ",Новый Структура("ТекстСодержания,Пометка",
																СтрокаРЗ.ТекстСодержания,
																СтрокаРЗ.Пометка));							
								КонецЕсли;
								
								Команда_ЗаДача1(ПараметрыВыполнения);
							
							КонецЦикла;	
						КонецЕсли;
						
			        КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		Иначе	
			Команда_ЗаДача1(ПараметрыВыполнения);
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

и процедуру «СоздатьНовыйЭлементСправочникаЗаметки»

Процедура Команда_ЗаДача1(ПараметрыВыполнения)
     
	СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения);
		
КонецПроцедуры	

Процедура СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения)
	//Создаем новый элемент справочника
	ТекущийОбъект = Справочники.Заметки.СоздатьЭлемент();
	
	ДатаТекСеанса = ТекущаяДатаСеанса();
	
	//Формируем текст для Содержания
	ФорматированныйТекст = Новый ФорматированныйДокумент;
	
	//Обрабатываем Параметры
	перТекстСодержания = "Заметка создана ";
	перПометка = Перечисления.ЦветаЗаметок.Красный;
	Если ПараметрыВыполнения.Свойство("ПараметрыРЗ") Тогда 
		Если ТипЗнч(ПараметрыВыполнения.ПараметрыРЗ) = Тип("Структура") Тогда 
			Если ПараметрыВыполнения.ПараметрыРЗ.Свойство("ТекстСодержания") Тогда 
				Если ЗначениеЗаполнено(ПараметрыВыполнения.ПараметрыРЗ.ТекстСодержания) Тогда 
					перТекстСодержания = ПараметрыВыполнения.ПараметрыРЗ.ТекстСодержания;	
				КонецЕсли;	
			КонецЕсли;
			
			Если ПараметрыВыполнения.ПараметрыРЗ.Свойство("Пометка") Тогда 
				Если ЗначениеЗаполнено(ПараметрыВыполнения.ПараметрыРЗ.Пометка) Тогда 
					перПометка = ПараметрыВыполнения.ПараметрыРЗ.Пометка;	
				КонецЕсли;	
			КонецЕсли;

		КонецЕсли;	
	КонецЕсли;

	//Добавили проверку регламент\форма		
	ФорматированныйТекст.Добавить(перТекстСодержания + ?(ПараметрыВыполнения.ВидЗапускаРегламент,"регламентом","вручную") + " в "+Строка(ДатаТекСеанса), Тип("ТекстФорматированногоДокумента"));
	
	ТекущийОбъект.Содержание = Новый ХранилищеЗначения(ФорматированныйТекст, Новый СжатиеДанных(9));
	
	ТекстHTML = "";
	Вложения = Новый Структура;
	ФорматированныйТекст.ПолучитьHTML(ТекстHTML, Вложения);
	
	ТекущийОбъект.ТекстСодержания	= СтроковыеФункцииКлиентСервер.ИзвлечьТекстИзHTML(ТекстHTML);
	
	ТекущийОбъект.ДатаИзменения 	= ДатаТекСеанса;
	ТекущийОбъект.Автор 			= ПараметрыСеанса.ТекущийПользователь;

	ТекущийОбъект.Пометка 			= перПометка;
	ТекущийОбъект.ДляРабочегоСтола	= Истина;
	
	ТекущийОбъект.Записать();
КонецПроцедуры

Записываем и заменяем предыдущую дополнительную обработку на эту.

Заполняем настройки.

Проверяем ручной запуск и регламеты

Проверяем результат:

В коде можно было бы проверки вынести в одну процедуру\функцию. Как вы видите просто безграничные возможности предоставлены программистам по разработке сложных регламентов без доработки конфигурации.

Отладка.

Отладку регламентов можно проводить по описанию из этой статьи Отладка подключаемых обработок

Корректную отладку запуска из формы можно производить после того как в Параметры.ДополнительнаяОбработкаСсылка будет закинута ссылка на добавленную дополнительную обработкую. В нашем случае, достаточно просто в процедуру формы "ПриСозданииНаСервере" добавить одну строчку.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	//Для тестирования ХранилищеНастроек
	Параметры.ДополнительнаяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоРеквизиту("ИмяОбъекта","БСП_ДО_Регламенты");
	ЗаполнитьЗаписаннымиДанными();
КонецПроцедуры

 

П.С. Пока писал данную статью в голову пришла еще одна по данной тематике.  БСП: Дополнительная обработка (Регламенты) + Расширения, примеры от сложного к универсальному

Скачать файлы

Наименование Файл Версия Размер
Дополнительная обработка (Регламенты) финальная
.epf 11,30Kb
09.05.18
8
.epf 1.0.8 11,30Kb 8 Скачать

См. также

Комментарии
Сортировка: Древо
1. Dream_kz 75 10.05.18 08:17 Сейчас в теме
Как раз нужны были примеры по запуску доп. обработок по времени + хранение настроек этих самых обработок. Спасибо
2. dsdred 353 10.05.18 08:21 Сейчас в теме
(1)
Как раз нужны были примеры по запуску доп. обработок по времени + хранение настроек этих самых обработок. Спасибо

Отлично, значит не зря писал статью.
3. rafaiil 10.05.18 08:51 Сейчас в теме
Отлично! Большое спасибо!;) Очень полезный для меня материал.
rutony; dsdred; +2 Ответить
4. TrinitronOTV 10.05.18 09:16 Сейчас в теме
Спасибо, пригодится
rutony; dsdred; +2 Ответить
5. jONES1979 10.05.18 09:18 Сейчас в теме
Эта статья интересна! Напишите еще одну, более интересную! :)
Max27; rutony; dsdred; +3 Ответить
6. dsdred 353 10.05.18 09:23 Сейчас в теме
(5)
Эта статья интересна! Напишите еще одну, более интересную! :)

Ну судя по тому, что статья быстро набирает положительные голоса. Скорее всего будет продолжение.
7. Ava1or 10.05.18 16:40 Сейчас в теме
Спасибо! Огонь статья!
Эх, написал бы ты ее месяцок назад... Но уже сам разобрался)
8. dsdred 353 10.05.18 21:30 Сейчас в теме
(7)Знал бы, что будет так интересна читателям, написал бы раньше))
9. serega33 11.05.18 11:51 Сейчас в теме
Вот интересно почему в БСП четко не прописали в описании как хранить настройки для регламентных обработок, в демо БСП есть пример с хранением, но такой же не очевидный как и у вас. В голову не ложится, вот кстати уже шаблон делали - https://infostart.ru/public/627824/
10. dsdred 353 11.05.18 12:01 Сейчас в теме
(9)Спасибо, не видел данную статью.
На счет описания 1с. Не знаю почему они пишут поверхностное описание. По сути желтые книжки могут служить только как справочник о том, что можно сделать и удобной подпоркой дивана если отпала ножка... А то как сделать google в помощь. Если не нашел сиди сам пробуй...

Да, в БСП есть пример (если кому понадобится)-> Демо: Загрузка номенклатуры из прайс-листа (профили безопасности)
Код сохранения настроек из обработки:

&НаСервереБезКонтекста
Процедура СохранитьНастройкиФормы(ДополнительнаяОбработкаСсылка, АдресФайла)
СохраняемоеЗначение = Новый Структура("АдресФайла", АдресФайла);

ДополнительнаяОбработкаОбъект = ДополнительнаяОбработкаСсылка.ПолучитьОбъект();
ДополнительнаяОбработкаОбъект.ХранилищеНастроек = Новый ХранилищеЗначения(СохраняемоеЗначение);
ДополнительнаяОбработкаОбъект.Записать();
КонецПроцедуры

чтение ПриСозданииНаСервере
11. Danilov 21.05.18 04:48 Сейчас в теме
Отличная статья. Возьму на заметку.
12. dsdred 353 21.05.18 07:26 Сейчас в теме
(11) На этой неделе будет продолжение. Вторая часть на 90% готова.
Оставьте свое сообщение