Коллекция полезных кнопок и процедур для отчетов и обработок v3.00

Публикация № 103905

Программирование - Работа с интерфейсом

587
Собрал в одном месте полезные кнопки и процедуры, которые по мере необходимости можно использовать в своих разработках.

Коллекция полезных кнопок и процедур для отчетов и обработок

  Данный внешний отчет представляет собой коллекцию полезных кнопок и процедур, которые Вы можете использовать в своих разработках. Для этого надо лишь скопировать нужные кнопки и соответствующие им процедуры в разрабатываемую форму.

  Для каждой кнопки можно назначить сочетание клавиш, которое позволяет быстро выполнить выбранное действие (так называемые "Горячие клавиши").


  Эта кнопка прилично экономит время при разработке и отладке внешних отчетов и обработок. Позволяет одним нажатием закрыть текущую форму и тут же открыть её заново (со всеми внесенными изменениями). Идею почерпнул в публикации //1c.digi-mas.ru/public/96548/. Спасибо ShantinTD.


  Это подменю "Вывод копии..." содержит три кнопки:
  1. Кнопка "в Excel (.xls)" открывает сформированный отчет (табличный документ) в Microsoft Office Excel или Open Office Calc, т.е. в программе, которая ассоциирована для файлов с расширением .xls.
  2. Кнопка "в Adobe Reader (.pdf)" открывает сформированный отчет (табличный документ) в Adobe Reader или в другой программе, которая ассоциирована для файлов с расширением .pdf.
  3. Кнопка "в Табличный документ" открывает сформированный отчет (табличный документ) в другом отдельном Табличном документе.


  Эта кнопка позволит отправить по электронной почте сформированный отчет (табличный документ) через Microsoft Outlook.
Вызываемая процедура сохраняет отчет в файл с расширением .xls, подготавливает письмо с вложением сохраненного отчета и открывает в Outlook сформированное письмо.


  Кнопка "Зафиксировать" является аналогом кнопки из меню "Таблица > Вид > Зафиксировать таблицу". Для быстрого доступа к этой функции данная кнопка вынесена на командную панель. Кнопка фиксирует/расфиксирует строки и колонки таблицы слева и сверху от активной ячейки.


  Кнопка "Печать с выбором принтера" для распечатки сформированного отчета. Перед распечаткой открывается диалог печати для выбора принтера, диапазона страниц и количества копий.


  Кнопка "Печать сразу" для распечатки сформированного отчета. Печать происходит без вызова диалога печати (печать с текущими настройками).


  На этой сервисной кнопке отображается время, затраченное на формирование отчета. При нажатии на кнопку показания обнуляются.


  Программно-сгенерированные кнопки, для управления уровнями группировки в отчетах. Теперь сворачивать-разворачивать группировки стало намного удобнее и быстрее, чем стандартно, через контекстное меню. Количество кнопок соответствует количеству уровней группировки сформированного отчета.
  Использованы доработанные процедуры из публикации //1c.digi-mas.ru/public/83915/.


В версии 2.02 (от 17.03.2012) добавлено:


  Группа кнопок для управления Периодом. "Выбор периода...", "Предыдущий месяц", "Текущий месяц" и "Следующий месяц".

  Первая кнопка
открывает форму для удобного и быстрого выбора периода (см. скриншот №2). В этой форме одним кликом можно выбрать любой стандартный период: Год, Полугодие, Квартал, Месяц, День. А поле календаря (внизу формы) позволяет выбрать вообще любой период. Для этого помечаем мышкой дату начала периода, а затем с нажатой клавишей Shift дату конца периода, и нажимаем кнопку "Выбрать".
Для большей универсальности, предусмотрена кнопка вызова "Стандартного диалога выбора Периода" (сверху-справа).
Использована доработанная форма из публикации //1c.digi-mas.ru/public/90540/ от Adeptus.

  Вторая кнопка сдвигает интервал Периода по месяцам назад (в сторону уменьшения).

  Третья кнопка устанавливает интервал Периода равным текущему месяцу.

  Четвертая кнопка сдвигает интервал Периода по месяцам вперед (в сторону увеличения).


  Добавлены процедуры для отображения трех индикаторов процесса (см. скриншот №3):
  
  Первый - стандартный индикатор, можно разместить в любом месте формы отчета. Он виден только во время формирования отчета.

    Два других индикатора (СКД-шный и текстовый) отображаются в строке состояния приложения.

    За основу взяты процедуры из публикации "Индикатор процесса в строке состояния ... ?...!". Спасибо, Шёпот теней, Абадонна и Душелов.


  Добавлена процедура для подсчета суммы выделенных ячеек в отчете.
 
  Реализовано два способа отображения суммы.

  Первый способ - отображение в элементе управления "Надпись". Может располагаться в любом месте на форме отчета.

  Второй способ - отображение в сворачивающемся элементе управления "Поле ввода". Располагается в самом низу формы, под полем табличного документа. Скрывается, когда ничего не выделено. Плюсом этой реализации является то, что текст суммы выделенных ячеек можно скопировать в буфер обмена.

  Алгоритм корректно считает также и суммы в нескольких несмежных выделенных областях. За основу взяты процедуры из обработки "Универсальная консоль отчетов" от  Evg-Lylyk.


В версии 2.03 (от 17.10.2012) исправлена ошибка::


Исправлена ошибка в форме "Быстрого выбора стандартного рериода":
При выборе Второго полугодия (кнопка "II"), вместо периода "с 01.07.2012 по 31.12.2012" устанавливался период "с 01.06.2012 по 31.12.2012".

Можно не скачивать эту версию, а сделать маленькое исправление в предыдущей версии:

В модуле формы БыстрыйВыборСтандартногоПериода, в процедуре ПолугодиеНажатие
в строке:
    Период.НачалоПериода = Дата(ТекГод, ?(ПорядковыйНомер = 1, 1 ,6), 1);

надо "6" исправить на "7"; т.е. должно быть так:
    Период.НачалоПериода= Дата(ТекГод, ?(ПорядковыйНомер 1, 1 ,7), 1);


В версии 3.00 (от 10.08.2014) добавлено:


 

  1. Добавлена кнопка-меню "Вывод копии...":
    - В это меню перенесена кнопка "в Excel (.xls)" и добавлены кнопки "в Adobe Reader (.pdf)" и "в Табличный документ".

  2. Доработана процедура "ПоказатьСуммуВыделенныхЯчеек":  
    - Теперь сумма подсчитывается только в видимых ячейках (скрытые ячейки игнорируются).

  3. Переписана процедура "кнОткрытьВЭксель_Нажатие".

  4. В процедуре "кнПереоткрыть_Нажатие" устранен мелкий баг, описанный в комментарии (168) от artbear.


 

    Читайте встроенную справку, в которой находятся подробные описания кнопок и процедур, а также способ перенесения нужного функционала в свои обработки. Внимание: после нажатия кнопки "Переоткрыть" встроенная справка перестает открываться.

  Для демонстрации работы кнопок реализован простой отчет, который имеет самостоятельную ценность. Отчет показывает количетво Документов каждого вида, количество элементов каждого Справочника и количество записей каждого Регистра сведений. При двойном щелчке по наименованию открывается форма списка выбранного элемента.

  Внешний вид отчета показан на первом скриншоте.

587

Скачать файлы

Наименование Файл Версия Размер
КоллекцияКнопокИПроцедур(3_00).erf
.erf 51,00Kb
20.06.15
2063
.erf v3.00 51,00Kb 2063 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. marsohod 121 09.01.12 07:02 Сейчас в теме
Жаль, что только для толстого клиента.
3. mtv:) 997 09.01.12 13:39 Сейчас в теме
(1)(2) Я никогда не работал с управляемым приложением, поэтому, к сожалению, ни чем не могу помочь.
Может найдутся спецы по управляемому приложению, и они смогут адаптировать... Мы бы сказали им огромное спасибо.
2. Программулькин 282 09.01.12 13:28 Сейчас в теме
есть возможность переделать для веб клиента?
4. rom-x 152 09.01.12 13:49 Сейчас в теме
А в 7-ке можно как-нибудь реализовать открытие таблицы в exel без записи файлов?
6. S.V.Y 09.01.12 14:02 Сейчас в теме
Забрал, плюс :)
(4) rom-x, можно, поиск рулит.
7. rom-x 152 09.01.12 14:26 Сейчас в теме
(6) valerka78, а по конкретнее?
У кого какие соображения?
8. S.V.Y 09.01.12 14:35 Сейчас в теме
(7) rom-x, http://infostart.ru/public/17464/ например.
Обсуждение в данной ветке прекращаем..
32. Maks888 1 12.01.12 09:14 Сейчас в теме
5. Uncore 09.01.12 13:57 Сейчас в теме
классный пост, автору большой плюс!
15. mtv:) 997 10.01.12 10:50 Сейчас в теме
(5)(11)(12)(13)(14) Спасибо за положительные отзывы, очень приятно. :)
16. OlegrVasil 10.01.12 12:56 Сейчас в теме
(15) Спасибище огромное за разработку.
9. CheBurator 3548 09.01.12 17:08 Сейчас в теме
ждем, когда в 8-ке появится такая удобная фишка как перехват любой открытой печатной формы (как в 7.7)...
10. Модератор раздела artbear 09.01.12 18:30 Сейчас в теме
(9) Уже есть такая фича :)
Как обычно, расширения 1С ищем на сайте 1С++ - можно по моему нику :)
11. diarki 09.01.12 21:40 Сейчас в теме
Автору однозначно плюс! Понравилась кнопка "Переоткрыть" полезная вне всякого сомненя - теперь вставляю ее везде... (открыл для себя много полезной информации) побольше бы таких публикаций.
12. S.V.Y 09.01.12 21:43 Сейчас в теме
(11) diarki, +1, такая кнопка рулила и в 7.7 :) Насколько меньше лишних движений.
164. v.l. 28.06.13 19:03 Сейчас в теме
(11) diarki, кнопка Переоткрыть существует в типовых дааааавным давно.
13. ogeniv 10.01.12 06:44 Сейчас в теме
14. Sam13 259 10.01.12 09:53 Сейчас в теме
Отлично. Полезно не только для использования, но и для расширения знаний. Особое спасибо за кнопки раскрытия группировок. Без них мучился.
17. ludai 10.01.12 13:29 Сейчас в теме
Переоткрыть - хорошая идея, да))
Остальные кнопки пока не заценила, возможно, тоже полезно.
18. OlegrVasil 10.01.12 13:34 Сейчас в теме
А можно ли настроить почту не на Outlook?
20. mtv:) 997 10.01.12 21:07 Сейчас в теме
(18) OlegrVasil, в данной разработке процедура для кнопки "Отправить" настроена на отправку почты через Outlook. Можно настроить и на подругому, но придется переписать процедуру.
Поиск тебе в помощь. Ссылок на Инфостарте много. К примеру вот ссылка -> Отправка почты из 1С.
19. dtitov 10.01.12 19:22 Сейчас в теме
21. Bober777 26 10.01.12 22:45 Сейчас в теме
А можно ли сделать пример для программного формирования файла с группировками в ёкселе.
24. mtv:) 997 11.01.12 10:34 Сейчас в теме
(21) Bober777, я, к сожалению, не знаю, что такое "ёксель"... :)
27. Bober777 26 11.01.12 12:39 Сейчас в теме
(24) У меня есть вопрос может ты мне поможешь?
Хочу программно сформировать XLS документ с группировками (плюсиками)
28. mtv:) 997 11.01.12 14:01 Сейчас в теме
(27) Bober777, Слету на твой вопрос ответить не смогу. А копать в этом направлении - просто нет пока времени. Извини.
Я бы твою задачу по быстрому решил так: Сформировал нужный отчет (с группировками) в 1С. Затем программно сохранил бы его на диске (с расширением .xls), а потом открыл бы его, если надо в Екселе.
Такая технология устроит?
29. Bober777 26 11.01.12 14:48 Сейчас в теме
(28) к сожалению нет, но что поделать значит самому придется копать)
26. Bober777 26 11.01.12 12:04 Сейчас в теме
(21) это XLS - я его просто так зову...
22. Гость 10.01.12 22:51
Прикольно , парадовала кнопка открытия в экселе и переоткрыть
23. VankaV 11.01.12 09:55 Сейчас в теме
Простенько и со вкусом.
Хорошо бы еще и для управляемого приложения ...
25. morpheus2 11.01.12 11:13 Сейчас в теме
Большое спасибо! Лично мне очень пригодится.
30. Imm 12.01.12 04:07 Сейчас в теме
Автору респект. Очень пригодилолсь
31. Imm 12.01.12 04:17 Сейчас в теме
33. mkostya 25 12.01.12 11:40 Сейчас в теме
Есть такая ошибка возможно не только у меня. Нарушается порядок страниц. Например я печатаю 3 страницы 3 раза. Он печатает 3 раза первую, 3 раза вторую и три раза третью. Как с этим можно бороться?
34. mtv:) 997 12.01.12 12:07 Сейчас в теме
(33) mkostya, А если в диалоге печати поставить галку "Разобрать по копиям", то помогает?
35. Stepa86 977 12.01.12 13:27 Сейчас в теме
Для упр. режима часть кнопок доступна и так в командах: http://screencast.com/t/1li9LmsU0A

Кнопку переоткрыть я вот так набросал:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Не ЗначениеЗаполнено( Параметры.ПутьКФайлу ) Тогда
		
		Параметры.ПутьКФайлу = ПутьКОтчету();
		
	КонецЕсли;
	
КонецПроцедуры

Функция ПутьКОтчету()
	
	Возврат РеквизитФормыВЗначение( "Отчет" ).ИспользуемоеИмяФайла;
	
КонецФункции



Функция ПолучитьИмяОтчета( адрес )
	
	Возврат ВнешниеОтчеты.Подключить(адрес);
	
КонецФункции

&НаКлиенте
Процедура Переоткрыть(Команда)
	
	адрес = "";
	
	Если ПоместитьФайл(адрес, Параметры.ПутьКФайлу, , Ложь ) Тогда
		
		Если Открыта() Тогда
			
			Закрыть();
			
		КонецЕсли;
		
		ОткрытьФорму("ВнешнийОтчет."+ ПолучитьИмяОтчета( адрес ) +".Форма", Новый Структура( "ПутьКФайлу", Параметры.ПутьКФайлу ));
		
	КонецЕсли;
	
КонецПроцедуры
Показать


где параметр ПутьКФайлу - ключевой. Чем заменить параметр не придумал, чтоб можно было без модификации формы обойтись.

Открыть в екселе почти так же выглядит:

&НаКлиенте
Процедура ОткрытьВЕкселе(Команда)
	
	#Если Не ВебКлиент Тогда
		
		ИмяФайла = ПолучитьИмяВременногоФайла( "xlsx" ) ;
		Результат.Записать( ИмяФайла, ТипФайлаТабличногоДокумента.XLSX );
		ЗапуститьПриложение( ИмяФайла );
		
	#КонецЕсли
	
КонецПроцедуры
Показать


для веб-клиента лень было получение временного файла писать

кнопку замера можно переписать используя подсистему "Замер производительности" из БСП, точность там до тысячных секунды

кнопки группировки не получится такими прям сделать, а их обработчик почти такой же

для отправки на почту в БСП есть подсистема "РаботаСПочтовымиСообщениями" куда можно так же приложить файлик
u_n_k_n_o_w_n; item; JohnyDeath; mtv:); +4 Ответить
37. fap82 3 13.01.12 10:09 Сейчас в теме
Очень полезно - спасибо.
39. webdimon 14.01.12 00:36 Сейчас в теме
Еще бы прикрепить к этому делу библиотеку картинок, та что от 1С.
40. mtv:) 997 14.01.12 09:04 Сейчас в теме
(39) webdimon, извини, не понял твоё пожелание: "...прикрепить к этому делу библиотеку картинок, та что от 1С".
Можно по-подробнее?
41. IEmelya 15.01.12 21:33 Сейчас в теме
42. Mig_Alm 16.01.12 13:47 Сейчас в теме
Судя по описанию обработка нужная. Как накоплю денег - сразу качну. Плюсик тебе!
43. Trofimov_M 16.01.12 17:10 Сейчас в теме
Переоткрыть - реально необходимая вещь, жаль раньше о ней не знал.
Спасибо, оч пригожилось
44. OlegrVasil 18.01.12 11:17 Сейчас в теме
Жалко, что у меня не получается к разным отчётам и докам прикрепить. А так...Интересная статистика)
45. mtv:) 997 18.01.12 11:23 Сейчас в теме
(44) OlegrVasil, извини, не понял, что не получается прикрепить к отчетам и докам? Поясни, если не трудно... :)
46. nll.jojo 19.01.12 14:16 Сейчас в теме
47. nll.jojo 19.01.12 14:17 Сейчас в теме
спасибо... очень удобно все
48. cpm-classica@mail.ru 23.01.12 11:45 Сейчас в теме
49. mtv:) 997 23.01.12 11:49 Сейчас в теме
(48) cpm-classica@mail.ru, если будут новые идеи, то обязательно дополню публикацию.
51. elena_77 23.01.12 18:30 Сейчас в теме
Интересные вещи. Пригодидись. Интересная кнопка переоткрыть. Спасибо. Тебе плюсик.
52. Zoba 14 24.01.12 00:05 Сейчас в теме
Спасибо. Оч полезная вещь.
53. Редкий Гад 24.01.12 09:52 Сейчас в теме
54. white125 25.01.12 02:07 Сейчас в теме
55. white125 25.01.12 02:07 Сейчас в теме
пополняться коллекция будет?
56. ivan_83 15 25.01.12 09:01 Сейчас в теме
Спасибо. Кнопочки "Переоткрыть" для отладки внешних обработок очень не хватало))
57. alexism 26.01.12 10:50 Сейчас в теме
Переоткрыть - реально необходимая вещь, жаль раньше о ней не знал.
Спасибо, очень и очень пригодилась. Буду тестировать на своих обработках.
В общем - автору - большой респект и увеличение коллекции )
58. agarkin 26.01.12 17:53 Сейчас в теме
59. Программулькин 282 27.01.12 10:31 Сейчас в теме
есть ещё идеи для управляемого приложения?
60. mtv:) 997 27.01.12 10:39 Сейчас в теме
(59) пока нету... Как только будут, так сразу же опубликую.
61. Программулькин 282 27.01.12 10:53 Сейчас в теме
Жаль, очень хочется для управляемого приложения, хотя бы "переоткрыть".
В принципе коллекция нужная. Молодец.
62. mtv:) 997 27.01.12 11:06 Сейчас в теме
(61) Так кнопка "Переоткрыть" для управляемого приложения есть в http://infostart.ru/public/96548/. Посмотри там...
Программулькин; +1 Ответить
63. Программулькин 282 27.01.12 11:46 Сейчас в теме
спасибо, но всё-равно жду от тебя твои кнопки конвертированные для управляемого приложения.
65. xbic 16 28.01.12 07:54 Сейчас в теме
66. asg1975 235 30.01.12 09:56 Сейчас в теме
Присоединяюсь к вышенаписанным респектам. Забираем в копилку полезностей!
67. hmv59 30.01.12 10:20 Сейчас в теме
И для меня весьма актуально!
68. Scukosan 30.01.12 11:13 Сейчас в теме
в последнее время часто стал писать различные отчетики, так что заберу)
из пожеланий кнопку предварительного просмотра отчета бы)
69. mtv:) 997 30.01.12 11:49 Сейчас в теме
(68) Scukosan, кнопку "Предварительного просмотра" добавить скорее всего не получится, т.к. стандартных средств 1С недостаточно.
Эта кнопка вообще-то и так присутствует в Стандартной панели. Хотя надо подумать...
70. RomanUzmov 41 31.01.12 08:53 Сейчас в теме
Отличная коллекция! Автору (+)
71. tchvlad 31.01.12 11:44 Сейчас в теме
Очень интересное решение, позновательно, спасибо
72. alice500 31.01.12 18:06 Сейчас в теме
73. Ionmuerto 01.02.12 12:33 Сейчас в теме
Для веб клиента не подойдет? Туда бы еще обработку табличных частей и обработку загрузки выгрузки в из Эксель.
74. mtv:) 997 01.02.12 18:26 Сейчас в теме
(73) Ionmuerto, Я никогда не работал с управляемым приложением, поэтому, к сожалению, ни чем не могу помочь.
Посмотри в (35) от Stepa86, он покопал в этом направлении, может быть почерпнешь для себя что-нибудь полезное.
75. pt_olga 62 01.02.12 21:20 Сейчас в теме
автору спасибо и за идею, и за её реализацию!
76. echo77 1076 02.02.12 06:45 Сейчас в теме
Не хватает кнопок:
- "Открыть публикацию на infostart.ru" (с картинкой логотипа инфостарт)
- "Плюсануть за публикацию" (картинку тоже с инфостарт)
77. mtv:) 997 02.02.12 07:22 Сейчас в теме
(76) echo77, Подчеркиваю, что это "Коллекция полезных кнопок и процедур".
А в чем полезность предложенных тобой кнопок - не пойму. :) Без обид...
Хотя, добавить их можно без проблем.
79. echo77 1076 02.02.12 18:17 Сейчас в теме
Добавьте пожалуйста.
Еще мне кажется, будет полезной функция, возвращающая сумму выделенных ячеек табличного документа.
Я бухгалтерам добавил эту функкциональность в свои отчеты - они были очень довольны.

Процедура РезультатПриАктивизацииОбласти(Элемент)

    НадписьСумма = "Сумма: " + ВычислитьСуммуВыделенныхЯчеекТабличногоДокумента(ЭлементыФормы.Результат)

КонецПроцедуры

Функция ВычислитьСуммуВыделенныхЯчеекТабличногоДокумента(ПолеТабличногоДокумента) Экспорт

    Сумма = 0;
    Для Каждого Область Из ПолеТабличногоДокумента.ВыделенныеОбласти Цикл
        Если ТипЗнч(Область) = Тип("ОбластьЯчеекТабличногоДокумента") Тогда
            Для ИндексСтрока = Область.Верх По Область.Низ Цикл
                Для ИндексКолонка = Область.Лево По Область.Право Цикл
                    Попытка
                        Сумма = Сумма + Число(СтрЗаменить(ПолеТабличногоДокумента.Область("R" + Формат(ИндексСтрока, "ЧГ=0") + "C" + Формат(ИндексКолонка, "ЧГ=0")) .Текст, " ", ""));
                    Исключение
                    КонецПопытки;
                КонецЦикла;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;

    Возврат Сумма;

КонецФункции
Показать
80. mtv:) 997 02.02.12 19:01 Сейчас в теме
(79) echo77, согласен, функция полезная. Надо будет добавить.
81. zuevnp 5 04.02.12 13:31 Сейчас в теме
82. agarkin 05.02.12 12:30 Сейчас в теме
83. Sean1s 8 05.02.12 18:56 Сейчас в теме
84. SSO 06.02.12 12:23 Сейчас в теме
Очень хорошее решение. Полезно и наглядно. Спасибо.
85. Aleksey-29 06.02.12 15:41 Сейчас в теме
Вот как только денежек накоплю сразу скачаю, а пока только читаю комментарии ... :(
86. AlexanderKai 07.02.12 16:51 Сейчас в теме
Да, иногда такие кнопки нужны в хозяйстве. Попозже скачаю.
87. Massimo 08.02.12 12:25 Сейчас в теме
Автору однозначно плюс! Понравилась кнопка "Переоткрыть" полезная вне всякого сомненя - теперь вставляю ее везде... (открыл для себя много полезной информации) побольше бы таких публикаций.
88. Rino 08.02.12 12:25 Сейчас в теме
Автору респект. То, что искал
89. yalo 08.02.12 13:30 Сейчас в теме
спасибо, пригодилось для собственной обработки
90. Dethmond 08.02.12 14:04 Сейчас в теме
Очень нужная вещь, большое спасибо)))
92. laeg 13 08.02.12 20:14 Сейчас в теме
Автору +++! Кнопка Переоткрыть самая полезная оказалась, - теперь вставляю ее везде...
93. v_id 95 28.02.12 16:23 Сейчас в теме
Спасибо, список полезностей пригодился. Автосумма кандидат на включение.
94. mtv:) 997 18.03.12 10:03 Сейчас в теме
Опубликовал новую версию 2.02

Изменения:
+ Добавлена группа кнопок для управления Периодом;
+ Добавлены процедуры для отображения трех индикаторов процесса;
+ Добавлена процедура для подсчета суммы выделенных ячеек в отчете:

Подробности на странице публикации.
95. magvay_k 60 20.03.12 13:46 Сейчас в теме
Спасибо большое, пригодилось!
96. Ejnar 21.03.12 23:22 Сейчас в теме
Спасибо! полезная информация и вся по делу, очень понравилось, подчеркнул для себя много нового - надеюсь еще будут пополнения.
Для разработчики было бы полезным добавить автосумму в отчеты.
98. mtv:) 997 22.03.12 07:18 Сейчас в теме
(96) Ejnar, спасибо за отзыв, очень приятно.
Только не понял, что ты подразумеваешь под "автосуммой". Объясни по-подробнее, пожалуйста.

Процедура для подсчета суммы выделенных ячеек в отчете - это не оно?
99. Ejnar 22.03.12 15:33 Сейчас в теме
(98) Извиняюсь, о печатался в последнем предложении - именно о процедуре Процедура для подсчета суммы выделенных ячеек в отчете - шла речь. Просто хотелось бы что бы эту идею подчеркнули для себя разработчики конфигураций и в будущем включили ее в стандартные отчеты.
97. daho 8 22.03.12 07:00 Сейчас в теме
Спасибо!!! Да не помешало б и для для тонкого клиента доделать.!
100. Lyuba-Lyuba 03.04.12 14:22 Сейчас в теме
Классно, классно! Ждем для тонкого!
101. MrVesna 16 03.04.12 23:47 Сейчас в теме
Пригодится не только для будущих отчетов и форм, но и для расширения знаний и кругозора.
102. Altair777 640 04.04.12 11:21 Сейчас в теме
Скачал, попробовал. Почти понравилось :)

Есть замечание по поводу кнопок управления группировками. Тулить процедуру их генерации в каждый отчет не есть хорошо. Перепишите процедуру для общего модуля, как это сделал я. Только для этого ей нужно передавать 2 параметра - форму и поле табличного документа.

Кстати, я ее еще доделал на случай нескольких табличных документов на форме - для каждой формируется своя ссылка на действие СвернутьДоУровня. Вот только к сожалению, не удалось эту процедуру перенести в общий модуль потому что действие кнопки требует процедуру обработки нажатия только в модуле формы.
103. mtv:) 997 05.04.12 05:40 Сейчас в теме
(102) Altair777,
Прочитал ваш комментарий, почти согласен :)

Ваше предложение переписать процедуру для общего модуля подойдет не для всех. Знаю много контор, где категорически против внесения любых изменений в конфигурацию. А те, кто правит свою конфигурацию, думаю сами смогут чуть поправить процедуру для переноса ее в общий модуль. Кстати у меня в рабочей базе так и сделано - в общем модуле. И несколько табличных документов на форме тоже обрабатываются.

В публикации основная идея и простая рабочая отлаженная процедура, для простого и быстрого переноса в новые отчеты. А кто захочет, думаю, допилит сам. Там ничего сложного нет. Да и вы в своем комментарии дали остальным хорошую подсказку, как можно усовершенствовать процедуру, спасибо.
SirYozha; Altair777; +2 Ответить
104. Altair777 640 05.04.12 10:23 Сейчас в теме
(103)
для простого и быстрого переноса в новые отчеты

Для простого и быстрого переноса мне пришлось тоже править отчет :)
Дело в том, что кнопки из командной панели копипастятся только в командную панель. А если надо на форму? Только руками.
Вот я и сделал еще одну форму, где кнопки на форме.

P.S. сорри за тавтологию. Но это еще фигня по сравнению с перлами от 1С.

Кроме того, в 1С:Предприятии 8 для манипулирования типами используются не их строковые наименования, а специальный тип "Тип". Значение типа Тип может быть получено функцией Тип(), получающей в качестве параметра имя типа.
Чтобы проверить тип значения переменной нужно определить ее тип функцией ТипЗнч() и использовать функцию Тип() для получения типа по имени.
altu71; mtv:); +2 Ответить
Оставьте свое сообщение